Delicious Digg Facebook Favorites More Stumbleupon Twitter

Vigil@nce – QEMU : boucle infinie de ehci_advance_state

Ce bulletin a été rédigé par Vigil@nce : https://vigilance.fr/offre

SYNTHÈSE DE LA VULNÉRABILITÉ

Un attaquant dans un système invité peut provoquer une boucle infinie dans la fonction ehci_advance_state() de QEMU, afin de mener un déni de service du système hôte.

Produits concernés : Fedora, QEMU.

Gravité : 1/4.

Date création : 18/04/2016.

DESCRIPTION DE LA VULNÉRABILITÉ

Le produit QEMU émule USB EHCI (Enhanced Host Controller Interface).

La fonction ehci_advance_state() du fichier hw/usb/hcd-ehci.c manipule une liste de SITD (Split Isochronous Transfer Descriptor). Cependant, s’il y a une boucle dans la liste, la fonction ehci_advance_state() ne termine pas.

Un attaquant dans un système invité peut donc provoquer une boucle infinie dans la fonction ehci_advance_state() de QEMU, afin de mener un déni de service du système hôte.

ACCÈS AU BULLETIN VIGIL@NCE COMPLET

https://vigilance.fr/vulnerabilite/…

Source:: Global Security Mag

Text Widget

Aliquam ut tellus ligula. Nam blandit massa nec neque rutrum a euismod t ellus ultricies! Phasellus nulla tellus, fringilla quis tristique ornare, condi mentum non erat. Aliquam congue or nare varius.